E1+e2Stuidoでデバックボタン(虫)を押下すると、COMポートが自動的に解除され、PC(TeraTerm)間でコマンドを送受信できなくなる

お世話になります。わたです。

もしも同様の現象が報告されているようでしたら、
情報を展開いただきたく投稿させていただきました。
要点は、デバッグを開始するとなぜPC上のCOMポートが解除されてしまうのか?です。

<構成情報>
PC :Windows11
デバッガー:E1
開発環境 :e2Studio(2023-10 (23.10.0))
自作基板 :RX111(R5F51116)+FTDI通信チップを使用し、PC(TeraTerm)からコマンドの送受信可能な状態
備考 :過去にこの組み合わせでデバッグ中もTeraTermからコマンドの送受信が可能であった

<手順>
①自作基板とPCをUSB-TypeCケーブルで接続
※デバイスマネージャー上(ポート(COMとLPT))では、COM21に割り付けられる。
②e2Studioのデバッグの開始ボタン(※虫ボタン)を押下
③②の直後に、Windows上で「USBデバイスは認識されません」との警告画面が表示され、
デバイスマネージャーのポート(COMとLPT)から、COM21が消え、
同じくデバイスマネージャー上のユニバーサル シリアル バス コントローラの、
"USB Serial Converter"に黄色のビックリマーク、若しくは不明なUSBデバイス(デバイス記述子要求の失敗)が出現する

尚、復帰するためにはUSBケーブルを一度抜き差ししないとこの③は直りません。


ハード面(別PC(Windows10)、別E1、別基板)、及びソフト面(e2Studio、FTDIの通信ドライバ)を
入れ替えてみましたが現象は変わりませんでした。
過去に全く同じ構成で問題なく使用できていたこと、別のPCでも同様の現象が発生することから、
何かのWindows Updateの影響では?を考えましたが、しらみつぶしにWindows Updateをアンインストールしていくことはできないため、
何か情報をお持ちであれば、と考えた次第です。

よろしくお願いいたします。

Parents
  • わわいです

    ふつう、USBの5Vラインからの電源供給で、FTDIチップのUSBからの仮想シリアルポートを使ってる場合、ターゲット側の状態が変わったからと言ってUSBのポートの状態が変わるというのはありえません。

    自作基板ということで、ここらへんの電源周りの配線が間違っている(あるいは設計が悪い?)ということはないでしょうか。

  • わわい様

    コメントをいただきありがとうございます。

    〉自作基板ということで、ここらへんの電源周りの配線が間違っている(あるいは設計が悪い?)ということはないでしょうか。
    Yamamoto様への返信にも記載させていただきましたが、
    半年前まではこの基板とE1を使って、デバッグ中も全く問題なくTeraTerm等からデータ送受信ができておりました。
    そのため、ここ辺りの配線に誤りがあるとは考えにくいと考えております。

    また、念のためハード設計者にも接続も含め再度確認していただいておりますが、
    同様に問題ないとの見解であり、これまでの結果を踏まえるとハード面というよりはソフト面を疑っております。

    個人的には、ここ最近のWindowsUpdateに伴いドライバ関連?なメンテが必要であるにも関わらず、
    E1はすでに生産も停止しているので、メンテされていないだけなのではないかとも感じている次第です。
    これは完全に想像でしかありませんが…

Reply
  • わわい様

    コメントをいただきありがとうございます。

    〉自作基板ということで、ここらへんの電源周りの配線が間違っている(あるいは設計が悪い?)ということはないでしょうか。
    Yamamoto様への返信にも記載させていただきましたが、
    半年前まではこの基板とE1を使って、デバッグ中も全く問題なくTeraTerm等からデータ送受信ができておりました。
    そのため、ここ辺りの配線に誤りがあるとは考えにくいと考えております。

    また、念のためハード設計者にも接続も含め再度確認していただいておりますが、
    同様に問題ないとの見解であり、これまでの結果を踏まえるとハード面というよりはソフト面を疑っております。

    個人的には、ここ最近のWindowsUpdateに伴いドライバ関連?なメンテが必要であるにも関わらず、
    E1はすでに生産も停止しているので、メンテされていないだけなのではないかとも感じている次第です。
    これは完全に想像でしかありませんが…

Children
  • FTDIを介したCOMポートがおかしくなるという話なら、E1は全く関係ないですよ。

    また、ソフトがどうであれ全く関係ありません。

  • ボードやPCを変えても再現するとのことで、「何か」あるのかと思って、

    ・Windows11(+WindowsUpdate最新)

    ・e2studio(2023-10)

    ・RX110

    ・FTDIのUSB-Serial変換IC(FT232RL)

    ・E1

    の組み合わせで、デバッガ接続してみました。…が、何も起こりませんでした。(私の手元の環境では現象が再現しませんでした。)

     今まで、キワキワで動いていたものが、何か微妙に条件が変わったことにより、キワのあちら側に行ってしまい、動かなくなったという事も考えられるのかと思いました。

     電源は、USBのPDは使わず、VBUS(+5V)から、FTDIのチップに入って、FTDIの3V3OUT(3.3V出力端子)をマイコンの電源にしている?(と推測)

     どのFTDIチップを使っているかは記載がありませんが、3V3OUTは50mAまで(手元にあるチップではそんな感じです)。50mAですと、RX111を駆動するのには十分かと思いますが、なにか他に電力を食う回路が無いでしょうか。

     デバッガ接続時には、デバッガから電源を「供給しない」設定でしょうか?(マイコンに電源が供給されている場合は、「供給する」設定ですと、接続時にエラーとなりますが、なにか上手くエラーをすり抜けて、2箇所から電源供給されおかしくなっているなどはないでしょうか。)

     一番考えられるのは、電源の問題でしょう(例え実績のある回路であっても、です)。

     私なら、デバッガ接続のタイミング(FTDIのチップがPCからUSBの異常と検知されるタイミング)で、VBUSとマイコンの電源3.3Vのラインをオシロで観測して、電圧降下が無いかを確認します。

     あと、FTDIのチップのリセット端子は、マイコンのリセット端子と接続されていますでしょうか(=デバッガからリセットが制御される回路になっている)。(ドライバのバージョン等で)リセットのタイミングが微妙に変わり、FTDIのチップの動作が変わったという可能性です。

    →FTDIのチップのリセット端子を回路的に切り離して、動作を見れば原因に関係するか判ります

    (再現性があるとのことですので、怪しいところをつつけば原因が判明するのではないかと思うのですが。)

  • Shoji Yamaoto様、わわい様、tf様

    纏めての返信となり、申し訳ございません。
    色々とご指摘いただきありがとうございます。
    結果報告にはしばらく時間がかかりそうだったので先にお礼のみ返信させていただきます。

    ちょうどRX63T向けのデバッグボードが手元にあったので、
    それで試してみたところ、デバッグ開始時も問題なくCOMポートも認識されております。

    電源周りをオシロで確認した結果、電圧降下などは見受けられませんでしたが、
    上記の通りデバッグボードでは問題ないため、問題個所をハード面に絞り、
    皆様からご助言いただいた観点で確認を進めます。

    尚、自作基板はデバッグボードとは通信ICが異なりますので、まずは自作基板のFTDIチップを別のICに載せ替える等、問題個所を特定していきます。進展があればご報告いたします。

  • Shoji Yamaoto様、わわい様、tf様

    ようやく原因が判明しましたのでご報告いたします。
    ご指摘の通りですが、結論から申し上げて自作基板(ハード側)の問題でした。

    自作基板ではMDピンに通信経路切り替えが割り当たっていたため、
    デバッグを開始した際にE1の出力と通信経路切り替えが競合し、
    通信動作周りで不安定になっていたようです。
    ハード的に通信切り替えを切り離すと、問題なくデバッグが可能となりました。
    なぜ昔は問題なくデバッグできていたかは不明ですが…

    色々とご助言いただき誠にありがとうございました。
    本報告を以てCloseとさせていただきます。