rzg2l-3.0.5 yocto系统,2个以太网和一个wifi,使用wpa在wifi获取ip后,会导致以太网节点掉

rzg2l-3.0.5 使用wpa获取wifi的IP后,以太网节点会掉。可能是 connman 网络管理影响的。 麻烦问一下,是这个原因吗?

现在不编译connman ,在获取wifi的ip后以太网节点就没有掉。但是如果不编译connman 就没有网络管理。现在在rzg2l-3.0.5 上编译 networkmanager 发现会报错,麻烦问一下,要怎么解决?

Parents
  • connman会自动管理系统的网络连接,当你连接了wifi网络后,它可能会认为wifi连接为最佳配置而断开ethernet连接,你试一下是否可以给connman配置优先级来控制哪个网络接口优先使用。

    例如编辑 /var/lib/connman/ethernet_xxxxxxxxxxxx_cable/settings

     /var/lib/connman/wifi_xxxxxxxxxxxx/settings

    添加Priority属性,让Ethernet的优先级高于wifi的

    [service_ethernet_xxxxxxxxxxxx_cable]

    Name=Wired
    AutoConnect=true
    Modified=2024-05-31T09:36:45.634079Z
    IPv4.method=dhcp
    IPv4.DHCP.LastAddress=172.28.28.9
    IPv6.method=auto
    IPv6.privacy=disabled
    IPv6.DHCP.DUID=000100012d326db8021122334455

    Priority=100

    修改后执行systemctl restart connman

Reply
  • connman会自动管理系统的网络连接,当你连接了wifi网络后,它可能会认为wifi连接为最佳配置而断开ethernet连接,你试一下是否可以给connman配置优先级来控制哪个网络接口优先使用。

    例如编辑 /var/lib/connman/ethernet_xxxxxxxxxxxx_cable/settings

     /var/lib/connman/wifi_xxxxxxxxxxxx/settings

    添加Priority属性,让Ethernet的优先级高于wifi的

    [service_ethernet_xxxxxxxxxxxx_cable]

    Name=Wired
    AutoConnect=true
    Modified=2024-05-31T09:36:45.634079Z
    IPv4.method=dhcp
    IPv4.DHCP.LastAddress=172.28.28.9
    IPv6.method=auto
    IPv6.privacy=disabled
    IPv6.DHCP.DUID=000100012d326db8021122334455

    Priority=100

    修改后执行systemctl restart connman

Children