Device Descriptor Request Failed USB Port Issue

Hello everyone, hope you are all well.

I've been having an ongoing issue that started over a year ago with my laptop. One day out of the blue one of the USB ports decided to not recognize anything I insert.
I've tried multiple devices with the same result. When I insert a USB device the notification sound plays that the device has connected and then it disconnects and says that
the device is not recognized. Recently however I connected an external hard drive and it remained connected for longer than usual, about 5 seconds. I was about to click into it when it disconnected.

I have check multiple websites for fixes and followed some of them with no success. Here is some of the stuff I tried:
  • Uninstalling all the devices in the Universal Serial Bus Controllers and then restarting.
  • Updating the drivers for all the USB devices and restarting.
  • Running a "chkdsk" command prompt thing that didn't seem to do much.
  • Attempting to follow the instructions of a SOLVED post on TomsHardware that required going into the registry and deleting stuff but I didn't continue as I was unsure.
Below I've listed the specs of my laptop just in case it's useful:
  • Acer Predator Helios 300
  • Windows 10 Home 64bit (Up to date)
  • Intel i5 8300H 2.30GHz
  • 8GB DDR 4 RAM 2666MHz
  • Nvidia Geforce GTX 1060 6GB DDR5
  • Samsung 960 EVO SSD 250GB
  • 1TB Hard Drive
  • Laptop is 2 years old.
The laptop is in excellent condition as I take care of my stuff. I hardly ever use the laptops keyboard and track pad as I have a USB keyboard and mouse. The laptop looks new.

NOTE: I have sent an email to Acer so waiting to hear back from them, if ever...

So any idea how to correct this issue with the USB port?
Thanks for reading.